Migración del error de proyecto Polymer .5 a 1.0

Estoy tratando de migrar mi proyecto del polymer .5 al polymer 1.0.

He instalado una nueva versión de biblioteca de polymer, elemento de hierro y elemento de papel. Pero estoy recibiendo un error de seguimiento:

polymer-micro.html: 63 Unkeught TypeError: prototype.registerCallback no es una función

Esta página no tiene ningún código como:

Polímero (‘menú de forma’, …

Además, he notado que la estructura del directorio sigue siendo la misma para los elementos centrales. No cambió a elementos de hierro / neón.

Entonces mi código usa la misma línea para importar htmls. P.ej:

Además, compruebe la captura de pantalla adjunta: enter image description here

La estructura del directorio puede ser la misma, pero los archivos presentes en el interior son diferentes, se pueden refactorizar o dividir en varios archivos. Como 0.5 y 1.0 no son compatibles, asegúrese de actualizar su código también. El cambio es grande y no es tan simple como simplemente actualizar tu biblioteca.

Consulte su guía de migración sobre los cambios que debería realizar. Puede que tengas que cambiar un poco. Las características que usa podrían ser obsoletas, por lo que deberá usar una alternativa más nueva. Los autores de Polymer han creado una herramienta llamada polyup para ayudar en la migración, así que échale un vistazo.