Información confiable de navegador cruzado en ContentEditable

Estoy buscando una lista de navegadores web que sean totalmente compatibles con el uso de ContentEditable. Sé que IE lo ha soportado desde 5 o 5.5, pero ¿qué pasa con otros navegadores? Sé que las versiones modernas de Chrome, Flock, Maxthon, Opera e IE lo admiten. Pero no me importan los navegadores modernos. ¿Qué pasa con las versiones anteriores de ellos, como IE 6/7/8, Safari, Firefox, Avast, etc, etc.?

No puedo encontrar ninguna información útil sobre esto. ¿Alguien sabe?

¡Gracias!

  • El blog WHATWG proporciona información confiable, pero no de todos los navegadores:

    Firefox 3, Safari 3, Opera 9, Google Chrome e Internet Explorer (desde 5.5)

  • caniuse.com también le ofrece una buena mesa (nuevamente, solo para navegadores populares)

contenteditable ya es compatible con los principales navegadores. El problema es el comando execCommand , por supuesto, el diablo está en los detalles.

Compatibilidad de detalles: http://tifftiff.de/contenteditable/compliance_test.html

Mesa con soporte para navegadores:

http://caniuse.com/contenteditable