Java versión secundaria menor no compatible 52.0

No puedo iniciar mi aplicación Java como un applet web en HTML (estoy usando HTML 4.01, sé que no funciona en html5). El mensaje de error que devuelve es:

java: Major.minor versión no compatible 52.0

Intenté degradar mi java JRE / JDK / SDK, pero sigo recibiendo el mismo mensaje de error. La versión actual de Java que estoy usando ahora es 1.8.0_05.

Su código fue comstackdo con la versión 1.8 de Java mientras se está ejecutando con Java versión 1.7 o inferior.

En su caso, parece que se utilizan dos instalaciones Java diferentes, la más nueva para comstackr y la más antigua para ejecutar su código.

Intente recomstackr su código con Java 1.7 o actualice su plugin de Java.

Tienes que comstackr con Java 1.7. Pero si tiene archivos * .jsp, también debe eliminar completamente Java 1.8 del sistema. Si usa Mac, aquí es cómo puede hacerlo.

Noté que en la configuración de Apache de Netbeans en la pestaña de servidores. puede indicar la plataforma para su aplicación web. Cambié a 1.8 y funcionó bien. (Estoy apuntando a la plataforma java 8 en mi aplicación). Espero que no pueda ayudar.

Supuse que openjdk8 funcionaría con tomcat8 pero tuve que eliminarlo y mantener openjdk7 solamente, esto solucionó el problema en mi caso. Realmente no sé por qué o si hay algo más que podría haber hecho.